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Chapter 1 About GLOBE
GLOBE (GLobal Oceanographic Bathymetry Explorer) is an application for processing and
displaying oceanographic data. GLOBE offers processing and display solutions of multisensor data within a single 3D environment represented as a globe.
Developed in Java, GLOBE is multiplatform (Windows, Linux, Mac for PLACA) with
architecture that allows users to develop and add new modules for processing and
visualizing data.
Developed by IFREMER, the software is used by the European project EMODnet
Hydrography for manipulating and creating digital elevation models. GLOBE is available for
free under a LGPLv3 license.
See
https://gitlab.ifremer.fr/fleet/globe/blob/09c55db4017a31158889f7d75b19795c2f1975ba/f
r.ifremer.globe.help/documentation/index.adoc#user-content-index-of-globe-softwaredocumentation.

Software and Installations
Getting started
How to retrieve GLOBE software
1. Go to the GLOBE web site
https://www.flotteoceanographique.fr/en/Facilities/Shipboard-software/Analyse-ettraitement-de-l-information/GLOBE (you can change the language with the button
on the top right)
2. Go to the download page (on the left-hand side, just below GLOBE entrance)
https://www.seanoe.org/data/00592/70460/
3. Choose your version and required platform
4. Log in or create a download account
5. Validate the license and your download should start
6. You will get a zip file.
Requirements
• Operating system: Windows 7/10, Ubuntu, MacOS
• System: 64 bits
• RAM: 16GB recommended (2GB minimum)
• Graphic adapter: minimum 2007 NVIDIA recommended

4

Important: Using an old version of your graphic driver can lead to a JVM crash as soon as
GLOBE tries to display any OpenGL view.
Installation
Windows and Linux
• Unzip the file in a directory of your choice,
• Click on GLOBE.exe (windows) or the GLOBE executable file (Linux)
Tip: Deploy GLOBE in a directory named with the version number, for example 1.5.178
Uninstall procedure
Users just need to delete the GLOBE software directory to uninstall it.
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Chapter 2 Concepts and user Interface
Views
The GLOBE interface has a viewer (like the Project explorer) that is displayed by the View
tab.
All views can be stored in stack like the three main areas seen by default (for example the
Lower Left Area, containing two views: the property view, and the parameter view). The
image below gives an example of the display configuration.

IMPORTANT: Each view can be moved, resized, set as full screen and reduced. The user can
configure their own display of view in order to best fit their need and hardware
configuration (display count and size) and field of interest.
Layer
A layer is a concept inherited from NASA Worldwind. A layer is any single object that is
drawn on the 3D GLOBE. It can be a 2D layer like a legend, or a 3D object like a surface map,
or a graticule.
Workspace
When a user starts GLOBE, a popup window appears and ask for a workspace location.
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The workspace is the directory used by GLOBE to store some of the data files and settings
specifics to a working project.
• In the workspace you have a file called session.xml which contains a list of all the
opened files and their status (typically visibility, colors and so on). This file is
automatically loaded at startup.
• There is a .cache directory which is used as a cache for GLOBE intermediate files and
indexes. This directory can be safely deleted before a GLOBE startup, if necessary,
files will be regenerated.
• The metadata directory is used by the eclipse framework used by GLOBE to store its
internal state
User Interface Overview
After workspace selection, the software starts and will be displayed as shown below:
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The main window is made up of several areas that are described below.
Menu bar functions
At the top of the application, the user can find a classical menu bar containing a set of
functions.
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•
•
•

•
•

The File menu allows you to manage session and main functions of the application
(Exit, Restart, etc.)
The Edit menu is a classical Edit menu allowing mainly undo redo actions.
The Tool menu is a very important entry point, allowing you to start all operations
that are not directly linked to a specific file. For example, Batch conversion of files
can be found in this menu.
The Window menu is a classical application entry allowing you to access preferences
settings, and to show specific views.
The Help menu displays shortcuts, a link to the active GLOBE forum and the help file.

File Menu Details
• Save session: The user can export a session in an XML file. The session contains the
list of all opened files.
• Load session: Load a session saved in an XML file. GLOBE reopens the data files.
• Take a screenshot: Take a screenshot of the application.
• Switch workspace: Switch the application workspace, the user can choose another
workspace. If so, the application restarts.
• Quit: Quit the application.
Edit Menu Details
• Undo: This function undoes the last action of the active view. It can be also done
•

with CTRL + Z hot-key or with
icon.
Redo: This function redoes the last action of the active view. It can be also done
with SHIFT + CTRL + Z hot-key or with

icon.

Notice: These two functions can be used only for data modification.
Window Menu Details
• Reset perspective: If you are in trouble with the different views (e.g. you cannot see
some of the views), Window-Reset perspective function closes and restarts the
software.
Help Menu Details
• This function opens the help pages and displays the version number.
Toolbar functions
• The toolbar displays a few current shortcuts like save, undo, redo, display of the
toolbox view, progress view, and the cache management
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Upper left area
The upper left area is an area dedicated to file and layer management. The two default
views for this area are the Project Explorer View and the Layer List View. More details about
those view can be found in the dedicated chapter
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Lower left area
The lower Left area is an area dedicated to displaying information and controls that are
contextual to a node or file selected in the upper-left area. The two default views for this
area are the Parameter View and the Property View

Main Area
The main area is dedicated to all editing and displaying views. It is, by default, used by the
geographic view to display all data in the NASA Worldwind GLOBE.
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How a Virtual GLOBE works
It starts with a 3D sphere split into tiles.

When zooming, tiles are subdivided according to the distance to the point of view.

12

Then an image is associated per tile.

And an elevation image: Nasa004.jpg[]
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Data are organized according this hierarchical approach per tile:
• Computed once
• Stored on cache on disk

https://en.wikipedia.org/wiki/Pyramid_(image_processing)
IMPORTANT: Consequence for the file system: The pyramid tiles are stored on the file
system in a dedicated directory (for Windows C:\ProgramData\WorldWindData) in two
subdirectories Earth (containing NasaWorldwind tiles, and GLOBE data containing GLOBE
tile data)
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Python in GLOBE
The GLOBE software package embeds a python environment and a set of python scripts.
More specifically:
• The python embedded environment is a miniconda python 3.7 with a set of classical
libraries for data science projects (like numpy, scipy, netcdf and so on).
• The set of script is a frozen view of the Ifremer pyat project
(https://gitlab.ifremer.fr/fleet/pyat)
File structure
In a GLOBE directory two folders contain the python software: the miniconda directory
matches the anaconda distribution and the required libraries and the pyat directory
contains the associated set of python scripts matching this GLOBE version.

NOTE

All integrated processes python code can be found in the pyat/pyat/app directory.

Process call
Scripts are integrated within the GLOBE software and can be called from the GLOBE
software through different means:
• Either from the pyToolBox.
The pyToolBox is a view showing all python scripts. It is callable from the entry in the
toolbar or through the menu Windows → Show View
• Or from the Tools menu like any other GLOBE processes.
One can recognize the python nature of a process with the icon
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Finally, through right click in Project explorer
All processes taking a typed file as an input can be called classically with a right click on the
input files
•
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Chapter 3 Views
Project Explorer
The project explorer is a view representing all the data managed in GLOBE in a hierarchical
tree structure made of nodes and groups.
Each final node represents most of the time layer displayed in the geographic view, or in
some rare cases a reference to a user file that is recognized by the software. In case of data
displayed, the visibility of the layer is controlled by the associated checkbox.
High level nodes serve as a group handling specific kinds of layers.
• Background Node handles generic NASA layers. Users can choose the GLOBE’s aspect
in the Geographic View by selecting or not selecting a layer in Background node of
the project explorer (for example enable or disable the visibility of the compass).
• Data Node handles imported user files and associated layers (i.e. your data). In this
node, a file is represented as a node called a StoreNode and each StoreNode can
have multiple layers. The best example can be a sounder file node, which is
represented by several layers (for example one for the navigation line, the other for
the water column data).
• Group Node are folder like structures that regroup data in order to facilitate
organization. These can be created in the Data Node only.
• Web Map Service (WMS) Node handles the WMS layers displayed in GLOBE.
• Shape Node handles surfaces and shapes drawn by the user on the GLOBE surface
(for more information, see the chapter HOW TOs in the official manual)
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Action
In project explorer, actions available are contextual to the node(s) selected. The list of
available actions can be retrieved through a right click on a node. This will:
• Display available actions specific to that very node
• Allow load/unload : details about loading status in layer explorer are given in the
chapter How to manage loading status in Project Explorer in the official manual.
• Allow Go To that will zoom the eye point of view to the selection area.
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•

Allow some action like rename or delete the note (mind that renaming a node does
not rename the associated file).

Advanced topics
Specific action and filters are available on project explorer view in the top-level filter area or
the blue buttons. See the chapters How to re organize my data in the project
explorer and How to use node filtering to set visible a large bunch of files in the official
manual for more details.
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Layer List
You can visualize the layer list of the treeViewer in "Layer List" tab. Each layer comes from
NASA Worldwind and are superposed over each other. This tab allows the user to change
the ordering of layers through drag and drop. The lowest layer in this list is displayed over
the other layers.

Parameter View
The parameter view gives an entry point to all actions specific to a single selected Node.
Controls are specific to each node, it could be management of color for Digital Terrain
Model (DTM) files, to water column control or display configuration for a specific layer.
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Example of a DTM Parameter View
Property View
All properties associated with the selected node in Project Explorer are available on this
view (name, path, file type, file format, ship name, survey name, geographic coordinates,
etc.)

Example of Property View for a DTM file
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Geographic View
The geographic view is a geographical 3D Viewer, providing an innovative and highperformance 3D viewer for data types such as DTM and WMS which are plugged into a
virtual GLOBE. This view is based on NASA Worldwind API
(https://github.com/NASAWorldWind/WorldWindJava)
It has been designed to provide:
• In-depth evaluation of data set content to assess the quality of a DTM (resolution,
coverage, quality) using basic GIS functionalities.
• Combining data layers such as sample location, sediment properties etc. Using WMS
from other data sources to assist end-users searching for data or analyzing
interactions between processes on the seabed or between the water column and
topographic features.
• Demonstrating the concept of making this type service available to end-users
without them requiring specific skills to install or to use the service.

General Controls and Mouse commands
Left Mouse Button = Hold this button down and move the mouse to rotate the earth to the
right or left, top or bottom.
Right Mouse Button = Hold and drag your mouse to tilt the earth to see the 3D views of an
area that has the NASA Shuttle Radar Topographic Mission (SRTM) data. You will not really
notice this function till you zoom in closer to a point on the earth.
Both Mouse Buttons = Zoom in and out of the Earth.
Scroll Wheel = Use this to zoom in and out of the Earth.
Keyboard commands
The help menu details all shortcuts available in the geographic view
Background layers
All background layers can be enabled/disabled by clicking on their respective node in the
Background entry in the ProjectExplorer View
Earth image
Background layers feature the Earth with the World Wind default layers:
• Stars background and atmospheric effects.
• Images of the Earth which are draped on the elevation layer:
o The Blue Marble (WMS) Next Generation May 2004, necessary to be able to
zoom in and view the Earth at each tier (further details can be found on the
NASA website as below:
http://earthobservatory.nasa.gov/Features/BlueMarble/BlueMarble_history.
php
o I Cubed Landsat 15m, Landsat images of the Earth which benefits from i3
algorithms, gives better resolution than Blue Marble, only visible when
zoomed into 50km http://worldwindcentral.com/wiki/Landsat
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United States Department of Agriculture NAIP images, only visible when
zoomed into 20km and is only visible over the United States as US Geological
Survey topographic maps
o MS Virtual Earth aerial : [Microsoft](http://en.wikipedia.org/wiki/Microsoft)
has allowed World Wind to incorporate [Virtual
Earth](http://en.wikipedia.org/wiki/Virtual_Earth) high resolution data for
[non-commercial](http://en.wikipedia.org/wiki/Non* commercial), uses
DigitalGLOBE very high-resolution world imagery derived from satellite and
aerial imagery, is only visible when zoomed into 50km. Can take a long time
to display. http://www.microsoft.com/maps/
• Political boundaries: yellow country borders (not very accurate)
• Place names: adds place names to the GLOBE.
• Continents are in white capital letters, oceans are in white letters, countries are in
white letters, bodies of water other than oceans are blue letters, physical features
(mountains, deserts, etc.) are labeled with orange letters, cities are labeled with
yellow letters. As you zoom in more features are labeled.
• Other layers: in addition, several tools can be displayed as background layers to
better locate the user in space and to assess the elevation or depth:
o World Map: small map seen in the upper left corner of the GLOBE display,
with a cross indicating the location the Earth where you click and zoom in.
o Scale bar: in the bottom right corner of the GLOBE display the scale at which
you are zoomed in.
o Compass: displays a compass in the upper right corner, with a red arrow
heading north.
o Lat-Lon graticule: network of parallels of latitude and meridians of longitude
overlain on the GLOBE’s surface using the Military Grid Reference System
(MGRS) to show location in geographic coordinates.
o Terrain Profile: displayed in the lower right corner, the terrain profile graph
of the visible elevation layer along a (yellow) line. The line is located in the
middle of the view unless the line is specified by the operator using
the Measure tool of the tools panel.
Elevation terrain Layers
Elevation data of the global DTM have been collected by the SRTM, the National Elevation
Dataset (NED) and the Advanced Spaceborne Thermal Emission and Reflection Radiometer
(ASTER). World Wind (WW) uses the SRTM 30 Plus for the bathymetry of oceans and
seas, which includes a combination of soundings and altimetric data at 30 Arc Seconds
resolution (approximately 1km).1
o

1

J. J., Sandwell, D. T., Smith, W. H. F., Braud, J., Binder, B., Depner, J., Fabre, D., Factor, J., Ingalls, S., Kim, S-H., Ladner, R., Marks, K., Nelson, S., Pharaoh, A., Trimmer, R.,
Von Rosenberg, J., Wallace, G. and Weatherall, P.(2009) \'Global Bathymetry and Elevation Data at 30 Arc Seconds Resolution: SRTM30_PLUS\',Marine Geodesy,32:4,355
\* 371), http://dx.doi.org/10.1080/01490410903297766
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Geographic View tools
Vertical exaggeration
The Geographic perspective enables a user to apply vertical exaggeration to the terrain
layers. The vertical exaggeration is common to both the WW global and the user terrain
models. Vertical exaggeration can be applied up to 20x which should suffice for most sea
floor representation.
• Measurement tool
The measurement tool can be used to retrieve the distance between two points on the
spheroid.
This tool is activated once you have checked the corresponding check box. The user can
point to profiles by clicking simultaneously on "P" key and click in the Main Panel. The
pointer then changes to a cross, and user can left-click points anywhere on the GLOBE.
When "P" is released, the user can change the position of one point of the path by left
clicking on it and drawing it to a new position. The same with "Alt" pressed will result in the
translation of the path.
The measure gives the approximate orientation and direct lengths of the segments.
If Terrain Profile Layer is selected, the cross section of the terrain along the path is displayed
in the lower right corner. When a user DTM is overlain on the GLOBE, the section displays
the elevation/depth of the DTM.
Once the measuring process is finished, the Elevation profile can be exported as a csv file
(Comma Separator Value readable by Excel) by clicking on the Export Profile button.
To erase and redo the measure, just uncheck and recheck the check box.
•

Measure Tool
Skirts activation
This function must be kept activated to eliminate artifacts sometimes observed using WW
(see in the square below).
•

After activation
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Before activation
•

Information retrieval
o Depth: Depth (or elevation) of the DTM is displayed for each position of the
mouse together at the bottom of the screen.
o Coordinates: Geographical coordinates are displayed for each position of the
mouse together at the bottom of the screen.
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Chapter 4. Processes
Overview of DTM Tools in GLOBE software
When DTM are loaded in GLOBE software some operations can be applied. This chapter give
details about the available operations for DTM. These tools are accessible by right clicking
on the DTM file from the Project Explorer.

EMODNET | Reduction
This tool reduces the DTM Cell size using a coefficient.
NOTE
•

It is possible to select more than one input file.

Choose the factor of reduction (2 to get a 1/16 DTM resolution from a 1/32 DTM).
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And click on Finish.
The resulting name gets the extension -Reduced_2 and is created in the same folder as the
input DTM.
The output file is created in the chosen folder.
•

Merge DTMs
When several DTMs need to be merged into one. For this tool more than one DTM is then
selected before right clicking to access the "execute" tools.
Two options are possible: Simple average or Fill missing values.
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Option1: Simple average
Window 1: Merge parameters
Choose the merging option (here Simple average).

For this option, the resulting cell depth is the average of the input DTMs cell depths.
In case of overlap of DTMs in the cell:
The CDI Id is set to the CDI Id of the most dominant dataset in the cell.
Vsoundings: Sum of all Vsoundings.
STDEV is reprocessed using STDEV and VSounding layers of each DTM which are present in
the cell.
Min and Max soundings are deducted from the Min and Max layers of the DTMs which are
present in the cell.
Define the name of the output merged DTM.
The spatial resolution, or cell size, is automatically detected from the input Reference DTM.
NOTE

All layers must be selected (default).

And then, click Next ->
Window 2: Geographic boundaries
Defines the geographic bounds of your region. These limits can be rounded.

29

And click Next ->
Window 3: Operation summary
The window summarizes the output parameters (number of input files, merge parameters,
geographic bounds, output file with numbers of cells processed).
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Then, click Finish ->

The output file is created in the chosen folder.
Option2: Fill missing values
A reference data set is defined (see window1). Each layer of the new grid is filled by the
reference grid. Then, the empty cells will be filled in successively by the other grids. The
priority order is defined by the list of the input DTMs.
The priority order of the DTMs can be also defined with the Quality Index (QI) factor. Option
for sorting the DTMs are proposed in the "multi column sort" tool and with the arrows on
the right of the windows. These allow the user to modify the priority ranking.
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Then, the following windows and parameters are the same as seen previously for the Option
1. case of merging with a composite grid like the GEBCO grid. In that case, we
select Depth and CDI as the 2 layers to be processed as the others are not significant for the
GEBCO grid. The output file is created in the chosen folder.
Reproject DTM
When the projection of the DTM needs to be modified.
NOTE

The output DTM is totally recomputed with the new projection.

Choose the new projection and modify its parameters if needed.
Choose the cell size of the output DTM.
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Click Next ->
Choose the name of the output file (reprojected) and the destination folder.

Click Next ->
Define the geographic extent of the output file (possible to round the values).
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Click Finish ->

The output file is created in the chosen folder.
Geobox update
When the geographic extent of the DTM needs to be modified.
WARNING: Geobox update will translate source cells in order to fill the new DTM.
If the new geobox is not shifted from an integer number of cell, this could lead to a slight
shift of the data. In that case you should rather consider using the Re-project tool.
Choose the name of the output file (-newgeobox) and the destination folder.
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Click Next ->
Define the new geographic extend.

Click Finish ->
The output file is created in the chosen folder.
Gap filling
When some cells of the DTM are empty and isolated, an interpolation can fill in these gaps.
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The algorithm will fill every node in each quarter around an empty value having a distance
less than mask size around the point. Then the four shortest valid points around the empty
cell are used to compute a linear interpolation to estimate the missing depth.

WARNING: The mask size defines the size of window centered on the interpolated grid
node. This value must be an odd number. It is better not to set it with a value greater than
7 (3 rows/columns around the center point - see the following figure).
Click Next ->
It is possible to apply this operation on a specific zone only. A .kml file gives the extent of
this area.

Click Next ->
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The name (with the suffix -interpolated) and destination folder of the resulting DTM file are
set up in this window:

Click Finish ->
The interpolation starts. All the layers will be interpolated.

The output file is created in the chosen folder.
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The DTM before interpolation (CALMAR survey / cell size = 3.75 arcsec).

The DTM after interpolation (mask size = 3).
NOTE

Depending on the result the operation can be run several times.

38

Smoothing
This tool averages the depth values in a box, which size is defined by the user.
NOTE

No layer is modified. New layers are created in the DTM.

Choose the name of the output file (smoothed) and the destination folder ->

Click Next ->
Define the mask size, which is the size of the moving window for smoothing.
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The window/mask size is defined as follow:

NOTE

The suggested size is 7. It means that 3 lines and 3 columns are considered all around
each smoothed grid node.

Click Next ->
It is possible to apply this operation on a specific zone only. A .kml file then gives the extent
of this area.
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Click Finish ->

The output file is created in the chosen folder.
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Linear transformation
When the DTM depth values need to be modified according to a linear
function f(x)=ax+b (e.g. the depth values of the DTM are positive and GLOBE software needs
them to be negative).
Choose the linear function parameters (a=(-1) if the depth value sign needs to be changed).

Click Next ->
It is possible to apply this operation on a specific zone only. A .kml file then gives the extent
of this area.
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Click Next ->
Choose the name of the output file (-linear) and the destination folder.
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Click Finish ->

The output file is created in the chosen folder.
Layers invalidation (reset cell)
Used when some depth values of the DTM cells are in error and need to be erased from the
grid. This tool resets the depth value of these cells.
Choose the name of the output file (-zeroed) and the destination folder.

Click Next ->
• a .kml file, gives the area of extent.
• one or more filter (s) which can be set up as shown on the following figure.
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Here, if the standard deviation is more than 20m, the cells will be reset.
Click Finish ->

The output file is created in the chosen folder.
CDI modification
If the CDI information is incorrect and needs to be updated, the CDI information is edited in
the second column.

45

Click Finish
The DTM file is updated (see its properties).
Consistency checking
To check the consistency of the new DTM created in GLOBE software some tests are
conducted on the grid layer values (e.g. Is the mean depth value between the max value and
the min one?).

When the check process is achieved, a text report is created:
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If there is no error message (as shown on the previous figure), it means that the DTM values
are consistent.
GIS Lines/columns shifting
The coordinates of the grid are checked to identify if the GLOBE DTM NetCDF format is
coherent with ArcGIS format. This operation validates the ability to drag and drop the
GLOBE DTM into ArcGIS to further study it.
A warning message appears to warn the user about the DTM format modification.

The process is achieved.
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Exporting DTM to Ascii file (e.g. EMODNET format)
(For more information, see the chapter HOW TOs in the official manual)
Export the final DTM to emodnet ascii format using Execute with > export to ascii.
• Window 1: Unselect export missing value to minimize the size of the resulting file
and choose emodnet ascii format. Then execute.
A .emo file is created.
Export to a DTM
GLOBE allows users to export soundings source files (mbg, xsf, txt) to .dtm.
This section gives a deep overview of the wizard options and parameters available.
Two entry points exists to create a DTM:
• Either through the menu Tools → Convert → Sounder Files to DTM
• Or select a .mbg or .xyz file in the Layer explorer, then right-click this file and
select Export to →DTM.

When selecting more than one file, the user can choose to create one DTM per sounder file
or one DTM for all selected file.
• The first wizard is then displayed, which allows the user to set the output file names.
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•
•

Then a second wizard is displayed for DTM parameters computation.
On the first page you have to configure the spatial representation you want to use,
and the cell size.
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•

On the second page, you can configure the default geographic zone on which you
define your DTM.
By default it is the exact bounding box computed from the input data.
If you use multiple input for one output, the default bounding box is the union of
input bounding boxes.
You can also manually define the bounding box. In this case, you can ask the
application to define a bounding box which is stuck to integer number of degrees arc
minutes.
In case of multiple input files and one DTM per file, the bounding box of each output
can be reviewed.
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•

On the third page, you can configure:
o the minimum and maximum depths taken in account,
o interpolation after computation, or not,
o limitation of the position of soundings to a contour given in a .kml file.
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•

The fourth page allows the user to:
o include CDI information contained in a text file,
o delete isolated values,
o take in account valid and/or invalid soundings.
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•

The fifth page allows the user to:
o choose which soundings are taken into account in the algorithm
o give a priority between the input files,
§ give a weight proportional to the quality factor,
§ select the soundings with the best incidence angle,
§ just merge all the soundings (simple average is computed)
o in case the user has chosen Priority option, define the priority list between all
input files.
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•

The sixth page allows the user to select which layers to export.
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•

The seventh and last page show a summary of the operation.
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Finally, just click on Finish
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Chapter 5. EDMOnet TOOLS in GLOBE
This chapter presents the tool set used specifically for EMODnet in GLOBE
Classical EDMOnet process
• Steps 1 to 3 describe how to process a single DTM from sounding data sets and
reduce them to a 1/16' grid. (all data providers)
• Steps 4 to 8 describe the merging of all contributions into a regional DTM. (regional
coordinators)
• EMODNET / Convert and reproject describes the tool available to input a composite
DTM and to convert it into an "EMODnet" file, compliant for merging with all other
contributions. (providers of composite product)
Step 1: Import files
In the Project explorer window, right click on Data, then go to Import > Load data files….
(You can also drag & drop the file on the Data node

•

Case of the text file format (.txt or .xyz) :
o The top part of the window describes the data format
§ Field delimitation symbol
§ Depth sign convention
§ Possibility to skip the first lines in case of header in your txt files
o The bottom part of the window shows an overview of the file: select the
variable for each row (latitude, longitude or depth) by clicking on the column
header.
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Click Finish.
• MBG file (Ifremer file format)
There is not any setup window to import these files. The software automatically zooms to
the MBG file extent (Geographic View).
• Import from other formats

NOTE

If the input file is a DTM from another software, you need to export it in a text format
(Lat/Lon/Depth), keep in mind the cell size AND the geographic parameters (ellipsoid
and projection). Then, you import it as a text file (see previously) and then convert and
reproject into a DTM with the EMODnet specs by using the
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EMODNET / Convert and reproject tool (see description of this tool).
Step 2: Single DTM (1/64, 1/32 or 1/16 arc of minute)
A single DTM will be created for each data file (CDI or CPRD).
In the Project explorer window, right click on the data file (TXT or MBG) and select Export >
Export DTM (Batch).

NOTE

It is possible to select more than one file as an input.

Choose the option create one DTM per file, in the first window.

Batch DTM parameters are then defined in different windows, in both cases (one or several
input files):
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Window 1: Directory and name of the output files (prefix and suffix can be used).

Click Continue ->
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Window 2: Definition of the projection and the spatial resolution of the resulting DTM.
WARNING: Be careful about the depth of the DTM you want to create. The cell size must
be adapted to the depth and the spatial resolution of the dataset.
As an indication about the cell size to choose the following table gives ideas of
the relationship between depth and cell size:
Depth

Cell size (arc second)

Less than 200m

1/128 to 1/64

200m to 1500m

1/64 to 1/32

Deeper than 1500m

1/32 to 1/16

NOTE

The cell size must also be consistent with the quality of the data set.

Choose projection Lat/Long and resolution in arc seconds.

Keep the Force recompute (clear existing caches) option selected (Default). The process will
then be more efficient especially if the DTM created has the same name as a previous one.
Click Next ->
The cell size values, depending on the chosen units, are presented in the following table.
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Arc-minute (')

Deg (°)

Sec ('') - rounded

Meters (m) - rounded

1/128

0.00013021875

0.469

14.469

1/64

0.0002604375

0.938

28.935

1/32

0.000520875

1.875

57.875

1/16

0.00104175

3.750

115.750

1/8

0.002083

7.500

231.500
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Window 3: Definition of the geographic box extent.
The geographical extent needs to be adjusted to round minutes:
Select the Redefine geographic bounds option. Then, you can either redefine the extent
values automatically clicking on the Expand to an integer number of angle minutes button
or do it manually.

In case, you have selected many data files as input of the Batch DTM tool, then choose
the automatic solution to individually adapt the geographical boundaries to round
minutes for each DTM.
Then, click Next ->
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Window 4: Option for the gridding algorithm.
For the Emodnet purpose, select nearest, do NOT apply any filter (min-max
filter or interpolation).

Click Next ->
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Window 5: Selection of the CDI_Id file to fill in the CDI_Id layer.
The CDI file is made of 2 columns: one for the name of the input data file and another one
for its identifier.
The layer identifier option activates the loading of CDI file which is needed to link the grid
cells with the corresponding data source.
Keep the Only valid sounds selection for the data to grid in the DTM.
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A new window summarizes the information of the CDI file loaded and its validity from the
SeaDataNet web catalogue.

Click OK, then Next ->
The syntax of the identifier is defined as follows:
• For data files associated to a CDI id:
Filename with extension<space>SDN:CDI:LOCAL:Edmo code_ local id
• For data files associated to a CPRD id:
Filename with extension<space>SDN:CPRD:LOCAL:Edmo code_local id
• For gebco data:
Filename with extension<space>GEBCO_2014
Example:
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In that case, the Id 486_38465 is composed of: 486, the Edmo code for Ifremer, and 38465,
the local id of the survey defined by Ifremer.
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Window 6: Choice of the DTM merge/priority criteria
Keep the default parameters.

Click Next ->
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Window 7: Choice of the DTM layers to process
Keep the default parameters.

Click Next ->
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Window 8: Operation summary
The window summarizes the output parameters (number of output files, rows, columns,
layers)

Then, if the information is correct, click Finish.
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Window 9: DTM generation

The output file is created in the defined folder.
Validation– Check:
You can check the resulting DTMs by using the Viewer.
In DTM properties view
Click on the name of the DTM created and check in the properties window (below layer
explorer tab):
• Boundaries (must be in round minute),
• CDI (must be present),
• Resolution (See equivalence table above)
In DTM parameters view:
The parameters view tab is available when you drag down the drop-down list of the DTM in
the layer explorer window. Click on the first layer of it, then check in this parameter view the
presence and value of all the layers in the DTM ( CDI / Depth / Min / Max / StdDev /
Vsounding ).
The created DTM is loaded in the Geographic View:
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Step 3: 1/16 DTM - Reduction
In the Project explorer window, right click on the previous DTM file of 1/32 resolution:
NOTE
•

It is possible to select more than one file as an input.

Go on Execute with -> EMODNET | Reduction,

72

•

Then choose the factor of reduction (2 to get a 1/16 DTM resolution from a 1/32
DTM).
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And finally click Execute.
The resulting name gets the extension -Reduced_2 and is created in the same folder as the
1/32 DTM used for the reduction.
But this DTM is not automatically loaded into the software.
•

Step 4: Merge DTMs
All the DTMs have been generated and/or reduced to the common 1/16 arcminute
resolution.
They will then be regionally merged into a single 1/16 DTM.
The merging operation is guided by two different options:
• 1: "simple average": Merge single DTMs by a simple averaging algorithm.
• 2: "Fill missing values": Fill in the regional DTM step by step with all available DTMs
using priorities between the input files (like a deconflicting tool).
Option 1 is recommended when merging a batch of files of similar characteristics. They can
be all DTMs registered with a CDI (sounding data), or all DTMs having similar Quality
indicators, or similar ages…(see also sort DTM by Quality index).
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Option 2 is recommended to fill in the gaps of the regional DTM by DTMs having a lower
resolution or a lower evaluated quality. This option will apply rank of priority between the
DTMs contributing to the regional grid. It is recommended to use this option to integrate
the composite DTM (CPRD) and the regional grid (like GEBCO grid).
Both options are described below.
Select all the concerned DTM then right click on them and go on Execute with > Merge
Simple.

Option 1: Simple average
Window 1: Merge parameters
Choose the merging option (here Merge Simple).
For this option, the resulting cell depth is the average of the input DTMs cell depths.
In case of overlap of DTMs in the cell:
The CDI Id is set to the CDI Id of the most dominant dataset in the cell.
Vsoundings = Sum of all Vsoundings.
STDEV is reprocessed using STDEV and VSounding layers of each DTM which are present in
the cell.
Min and Max soundings are deducted from the Min and Max layers of the DTMs which are
present in the cell.
Define the name of the output merged DTM.
The spatial resolution, or cell size, is automatically detected from the input Reference DTM.

NOTE

All the layers must be selected (default).

And then, click Next ->
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Window 2: Geographic boundaries
Define the geographic bounds of your region. These limits can be rounded.

And click Next ->
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Window 3: Operation summary
The window summarizes the output parameters (number of input files, merge parameters,
geographic bounds, output file with numbers of cells processed)

Then, click Finish->

The output file is created in the chosen folder.
Option 2: Fill missing values
A Reference data set is defined. Each layer of the new grid is filled by the reference grid.
Then, the empty cells will be filled in successively by the other grids. The priority order is
defined by the list of the input DTMs.
Select the files to processed, then right click on them, and go on Execute with > Merge Fill
missing values.
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Window 1: File to Process

The associated Quality Indicators are extracted from the web databases. These indicators
can be used to sort the files with respect to their values. The files retained for processing
will be the checked ones. The arrows on the right allow the user to modify the rank of
priority

NOTE

You can get several interactions with the files like Go to and Highlight by right clicking
on them.

You can modify the sort order and criteria by expanding the "Multi column sort" area
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Then, the following windows and parameters are the same as seen previously for Option1.
Merging with a composite grid like the GEBCO grid.
In this case, we select Depth and CDI as the 2 layers to be processed as the others are not
significant for the GEBCO grid.
The merged DTM is created in the chosen folder but it is NOT loaded automatically.
Operations on DTM
Some operations are possible on DTM (interpolation, smoothing etc.). These tools are
accessible by right clicking on DTM files from the Project Explorer.
EMODNET / Convert and reproject
This tool is made to import and convert a grid file or a CPRD product, which has been
processed using another software or different parameters than thus defined by the
EMODnet Bathymetry methodology.
As Input file, you must have an “asci” file with the 3 rows, Longitude/Latitude/Depth, as the
export file of your grid. This file is input in GLOBE using the “import/load data” tool.
Then, you can use the “Export to / EMODnet / Convert and reproject” tool: it will reprocess
your grid asci files into the required standard grid format for the merging process.
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Reproject DTM
The following windows have to be filled in.
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First parameters windows: DTM generation parameters
Here the projection and cell size of the output DTM are defined.

Second parameters windows: name of the output file
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Next window is to define the geographical boundaries of the new DTM.
Choose options "Redefine geographic bounds" and "Expand to an integer number of angle
minutes". With both options, the grid will fit with the EMODnet grid characteristics.
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